Advertise here

ALL CARVER CASCADE WATER HEATER, GAS FIRE, FANMASTER,P4 QUESTIONS HERE

Showing results 4041 to 4052 of 4052.

Darren
Joined Aug 2010
3 posts

Hi there

I put this is the wrong place to start with.

Hope you can help. I've recently purchased a caravan fitted with the Carver Cascade 2 GE water heater. It works fine on the 240V, but I can't get it to operate on gas. When switching on, all I get is the yellow & red lights on. There doesn't appear to be a cause for this combination in the instruction manual. I've got gas going to the fridge, oven & fanmaster, all these work ok. Can't hear the burner trying to ignite at all.

Thanks in advance

Darren

Wednesday, 29 May 2013

Discussion Archived

Rick
Joined May 2013
1 posts

Hi Tara, Did you have any result about the control knob rod that broke away from the ignition unit. I've got the same problem and want to know if there is a "fix" before I start trying to cobble something together. Cheers, Rick.

Wednesday, 29 May 2013

Discussion Archived

stewart jubilee
Joined May 2013
1 posts

hi as new to this, i would like to say that after i found your site , i was able to fix the problem with my Carver cascade 2, i took out the burnner modulea very easy job after i followed gary's instructions mate your a star, then took said unit to work and blew out the unit and holes with a air line, ( saftey glasses on and gloves worn and steel toecaps, incase any H & S wommbles on here ) left to warm up in oven for 30 mins then reasembled and big blue flame all the way along, and piping hot water 20 mins later, thanks all and happy caravaning. stewart

Wednesday, 29 May 2013

Discussion Archived

twydall25
Joined Jul 2013
1 posts

I have a cascade 2 water heater in my converted panel van, I was testing it to see if was working when I noticed high preasure leak comming from the inlet water conection at the top right side it is a plastic nut with pipe conecter all in one, I tryed to tighten it but it cracked and snaped off, is there any place I can get a reiplacement please help ???.
Its the same problem stephdebs had posted 11 august 2012

Tuesday, 2 July 2013

Discussion Archived

spencer
Joined Oct 2006
98 posts

iirc yellow is low voltage and red no gas

Tuesday, 2 July 2013

Discussion Archived

Dorrance
Joined Jul 2013
1 posts

Help!!
I have a carver cascade rapide ge,and though the gas side of it works great, the electric immersion part doesn't. I'm getting power into the multiblock and the little relay clicks when I switch it on at the wall but it just doesn't heat any water. I've checked the reset button and its ok. Is it the element?
Any help would be appreciated !

Monday, 15 July 2013

Discussion Archived

emmysnail
Joined Jul 2010
1 posts

Hi,

So many posts I can't trawl them all so apologies if this has been answered before...

We have a Carver Cascade 2, the type with an electric switch as well as the gas panel switch with the 3 lights. I have ensured it's full then turned the gas on, it goes green and remains green but water isn't heating up...have also tried with the electric switch on but again water doesn't heat up.

Can anyone suggest what might be the issue, we are away all week and I'm having to boil the kettle to get hot water!! (thank fully we're on a site with showers!)

Thanks, Emma

Sunday, 4 August 2013

Discussion Archived

mike
Joined Jul 2010
26 posts

Hiya, make sure your gas pressure is correct!
If it is, "Scrap the cascade" they are very-very old & not worth the trouble they cause!


Mike.

Sunday, 4 August 2013

Discussion Archived

Maggoo
Joined Aug 2013
2 posts

Hi All
Looking for some advice, It may well have already been covered, however, its a lot to go through all of the posts.
My issue is with a carver cascade 2.
When switched on, the green light comes on (you then here the clicking) clicking stops and then red light comes on.

I have stripped the flue down, when switched on the gas is igniting but it continues to try and ignite, approx 10 secs later the flame goes out (Valve Closes), which i presume is when the red light illuminates on the control board.

I have also removed the burner module along with the PCB, it is dry and no corrosion on PCB.
Any help would would appreciated

Saturday, 10 August 2013

Discussion Archived

mike
Joined Jul 2010
26 posts

Check your battery & your cold water inlet valve. If they are both ok.
then bin the Ancient Carver 2. They are not worth the trouble!!
Mike.


Mike.

Saturday, 10 August 2013

Discussion Archived

Adverts Currently On Preloved

Place an ad here for free

» More caravans ads...

Maggoo
Joined Aug 2013
2 posts

All fine.
I was hoping for a more informative answer tho.....
It seems mike that you do not like carver, do u have a cheap alternative in mind?
As a repair would be cheaper

Saturday, 10 August 2013

Discussion Archived

Ronnie
Joined Aug 2010
9 posts

Check your gas, if pressure is low it wont work

Thursday, 26 September 2013

Discussion Archived

Showing results 4041 to 4052 of 4052.


Important Note

All messages are submitted by visitors to this web site, and represent their own personal opinion. They do not necessarily represent the views or opinions of Preloved.

You use this information at your own risk. Preloved can not be held responsible for any damages or loss resulting from the use of this site. Please see our Terms and Conditions for more details.