Advertise here

Fiat punto heater problems

Messages 1 to 20 of 22.

calakaf
Joined Jan 2005
1 posts

My wifes punto overheated (surprise surprise) in the summer needing the head to be skimmed and gasket replaced. I`ve noticed since, in the cold mornings it doesn`t start so well. seems to splutter for about first 300 yards then is fine. Also with the frost being here if you start it in the morning and leave the heater on for a while it is still cold no matter how long you leave it. Once you start driving it heats up no problem. Tonight though my wife phoned to say the heater isn`t working at all now. What`s the problem?

Saturday, 1 January 2005

Discussion Archived

John H
Joined Nov 2002
221 posts

As I understand it -

Check the coolant level now.

Spluttering in the first few hundred yards _can be caused_ by the head gasket not being completely fixed: odd drop of coolant in a cylinder or two. Although damp plug leads may give similar symptoms.

Loss of heater (provided the engine is actually warming up (thermostat stuck open?)) is loss of coolant/air in the system - the heater is the highest point: this is also typical of head gasket problems.

The Punto cooling system is apparently very difficult to bleed properly so that there is no air in the system - if you get air trapped in the cylinder head you get localised overheating, causing head gasket failure.

For me it mostly points back to the head gasket - who did the repair in the summer? is it still under guarantee?

Sunday, 2 January 2005

Discussion Archived

moz
Joined Dec 2004
701 posts

iagree with john h .i done the same job on a xreg punto 3 months ago .did you have it pressure tested as well . the one idone i had to change the heater matrix as well. not a nice job beleive me..and it must be bled off correctly........moz

Sunday, 2 January 2005

Discussion Archived

davidjfarr
Joined Dec 2004
27 posts

on my r reg mk 1 there is a bleed valve on one of the heater hoses at the rear of the engine.

i recently changed the coolant to make sure i had enough anti-freeze and on re-starting had very similar problems to those you describe.

i diagnosed an air lock and started looking for a solution.

at the back of the engine, in one of the thinner (about 1" dia)hoses connected to the heater, you'll find a sort of junction with a plastic screw. this is the bleed valve - just like you'd find on a radiator.

i left the engine running and opened the screw a few turns. air bubbled out so i knew i was on the right track.

i did this three times before the problem was solved - but its all ok now

hope that helps

df

Sunday, 2 January 2005

Discussion Archived

pugz04
Joined Jan 2005
9 posts

I have a mk1 R reg punto, about two months ago I put the heaters on and you could smell what i thought was fish at first coming out, after about 5mins of running them it went and the car heated up, now tho something is wrong with it, the engine temp goes up fairly quick and is near the red line after a short trip, i dont think the rad fan works anymore and it seems to be leaking oil out of the rocker gasket, the rubber gasket is fine, as i checked it the other day.

Heating system is working properly either, it heats up slowly, but will only get really warm when i speed up, soon as i slow down it goes cold.

The oil is now black! could this be related to the head gasket problems mentioned? please help me out as i dunno whether i am safe to drive it properly.

Sunday, 9 January 2005

Discussion Archived

neil
Joined Jan 2005
2 posts

Hi chaps/chapesses, I recently purchased a Punto 55 1.1 injection model on an 'N' plate and found it to have erratic running problems when it warmed up, a trip to the garage resulted in new coil,HT leads and plugs being fitted,this cured it for a couple of days but has since recurred.Everything is fine until it warms up then upon pulling off ie:- traffic lights etc it dies coughs splutters unless I boot it and slip the clutch,on pulling up hills it also dies for a moment then picks up again,this seems to be more prelevant between 35-40mph,its my first fiat so not too sure about the engine config as to start repairs,any ideas out there ?

Tuesday, 25 January 2005

Discussion Archived

sep
Joined Jan 2005
1 posts

i had then same problem, heater smelling and overheating. i found out it was the fan not workin. i fixed it by changing the senor that cuts the fan in. it only lasted a week or two and then started happenin agen!

Thursday, 27 January 2005

Discussion Archived

pugz04
Joined Jan 2005
9 posts

I had the same problem with mine, Might sound silly but have you checked the rad coolent? I checked mine and thought it was full, car kept overheating and smelling, then the heating didn't work at all. It was only when i took it for an MOT that i found out that there was no coolent in the rad at all!!

Just a quick suggestion!

Friday, 28 January 2005

Discussion Archived

pugz04
Joined Jan 2005
9 posts

not only check your coolent level, also try and find out if its got an air lock in the rad pipes! thats a combined cause of smelling and overheating!

Friday, 28 January 2005

Discussion Archived

jami
Joined Sep 2004
14 posts

Hello there pugz04, just wondering what you had to do to get the coolent into the rad?
thanks

Monday, 31 January 2005

Discussion Archived

Adverts Currently On Preloved


FIAT PUNTO ACTIVE


WHEEL CHAIR ADDAPTED VEHICLE


FIAT DUCATO 2005


2009 FIAT DUCATO RAPIDO...


FIAT STILO 16V DYNAMIC 2002


BESSACARR E 460 2 BERTH...


ROOF RACK


FIAT PANDA 1.2 DYNAMIQUE...

Place an ad here for free

» More fiat ads...

moz
Joined Dec 2004
701 posts

open the bleeder on the top of the radiator pour the coolant in .it will force the water out .then when theres enough coolant in just tighten the bleeder up.....moz

Tuesday, 1 February 2005

Discussion Archived

pugz04
Joined Jan 2005
9 posts

Hi there jami, think moz has got that one covered! either way i hope it solves your problem!! let us know how it goes.

Tuesday, 1 February 2005

Discussion Archived

jami
Joined Sep 2004
14 posts

Nice one moz, I'll see if it works.Thanks guys!

Tuesday, 1 February 2005

Discussion Archived

Markus
Joined Feb 2005
2 posts

Thanks a million!!!!!!!!!!

Your advice has solved a really bugging problem with my Punto!

Now I can enjoy a really toastie drive like before!!

Saturday, 5 February 2005

Discussion Archived

pugz04
Joined Jan 2005
9 posts

No probs mate! Just a quick note for everyone, I've just opened a new website on puntos, it's not brilliant but i feel it's got potential, i'd appriciate it if you'd check it out! it'd be nice to get some positive feedback and i'd also like to know of any ideas you have about it. Cheers, the link is: http://www.spiritodipunto.vzz.net

-Pugz-

Sunday, 6 February 2005

Discussion Archived

chaz
Joined Feb 2005
1 posts

Hiya

Im having some problems with my heating in my fiat punto; air is blowing out, but it never warms up no matter how high the temperature is set, also occassionally, the red signal for the coolant comes on for a few seconds and then goes off,

Any ideas????

Thursday, 17 February 2005

Discussion Archived

BigWig
Joined Feb 2005
1 posts

Hey ya!

Is it a gold punto? If so you probably need to sell it soon.
And, yeah, u should shack up with that guy for sure!!!!!!
Share his car...

Eazy.

Thursday, 17 February 2005

Discussion Archived

Julian
Joined Feb 2005
2642 posts

Hi, in reply to neil,
Get your garage to check the coils, these have a tendancy to pack up.
Regarding All of the threads, Check that the heater matrix isn't leaking onto the ECU Punto's have a known fault with this and it can be very expensive to fix.

Thursday, 17 February 2005

Discussion Archived

Johnson
Joined Mar 2005
2 posts

Hey there people.. i have bought a Fiat Punto 1.1 "N" reg about 5 months ago it was all good ran smoothly but now i am faced with alot of trouble!, of which have been flooding in recently.. the first problem is that the radiator fan does not WORK AT ALL... a few days back it used to oddly start when i connected the battery terminals and never turn off! but now its completely dead.. i have checked all the fuses and they are fine. My headlight only stays on Dipped n sumtimes work on Beam! oddly the blue full beam indicator is always on?. Apart from these two problems the care has been pretty fine and is quiet smooth... SOMEONE please help me. Is it the Relay and Switch? Is there any FIat garage in London that you guys know to be reliable and not a money THIEF... please guys help me as i am stranded without a mechanical thinking cap on :(? Thank You Chaps

Saturday, 5 March 2005

Discussion Archived

jm
Joined Mar 2005
1 posts

Urgent advice needed! I bought an R reg punto through private sale before Christmas for £1500. Since then I have had staggering heater problems which have all seemed exactly the same to me - loss of heat in the car followed by rapid engine temperature increase - but each time I am told its a different problem. I have so far spent over £700 on it - once on new water pump, once on new heater matrix, and it has happened AGAIN. This time I am being told that I have a leak from the core plug behing the gear box and that it will cost me £400 plus VAT to fix, and that there is a risk that other parts including clutch could have been damaged.

I had a perfectly good Punto before this one until someone smashed into the back of me and it was written off - only got £800 for it on insurance!

Now I'm not sure whether to do this job or to abandon it completely for fear that something else will happen to the heater system - any advice gratefully received!

Wednesday, 16 March 2005

Discussion Archived

Messages 1 to 20 of 22.


Important Note

All messages are submitted by visitors to this web site, and represent their own personal opinion. They do not necessarily represent the views or opinions of Preloved.

You use this information at your own risk. Preloved can not be held responsible for any damages or loss resulting from the use of this site. Please see our Terms and Conditions for more details.